latest stable versions: v140614 (changelog)

Old Forums (READ-ONLY): The community now lives at WordPress.org. If you have an s2Member® Pro question, please use our new Support System.

S2Member and LoginWithAjax : issue ?

Home Forums Community Forum S2Member and LoginWithAjax : issue ?

This topic contains 10 replies, has 6 voices.
Last updated by  Cristián Lávaque 1 year ago.

Topic Author Topic
Posted: Wednesday May 22nd, 2013 at 10:02 am #50369
lorem bolo
Username: lorembolo

Hi,

I’m trying to use s2Member to manage content for “premium” users.
In combination, I also use Login with Ajax (LWA).
Unfortunately, it seems that S2Member has an issue with LWA.

On this page : http://artisti.bernardcousin.fr/ventes-privees/

If I log as an admin, everything is fine .But if I want to log as a level1Account (try with : testeur/testeur), the animation is loopin , nothing seems to happen .
Same problem if I want to register : even if everything works, the waiting animation loops…

Do you have an idea of how I can fix this ?
Thanks in advance

List Of Topic Replies

Viewing 10 replies - 1 through 10 (of 10 total)
Author Replies
Author Replies
Posted: Monday Jun 3rd, 2013 at 7:19 am #51210
vihegay
Username: vihegay

I have similar problem… i use LWA plugin with s2member since one year, there was no any problem. But since LWA has been updated (?), i have two problems :

1) as Lorem Bolo explained, “the animation is loopin, nothing seems to happen” and the page is not refreshed.

2) however members are logged in, when they refresh the page or they go to another page, they are logged in. BUT ! There are some members who are blocked completely since this incident, s2Member blocks them completely. When they try to log in at the WP login page (www.mywebsite.com/wp-login.php/), always the same error message appears (row translation) :

“503: Service temporarly inaccessible
Too many IP addresses access to a unique secured space!
Please contact the admin.”

When i disable s2Member plugin, the member can log in !

Posted: Monday Jun 3rd, 2013 at 7:25 am #51211
vihegay
Username: vihegay

I forgot to say that those both problems (looping animation and login issue) do not affect the login of the admin, only members !

Posted: Tuesday Jun 4th, 2013 at 4:02 pm #51347
Guy B
Username: gecko_guy

Same problem here. Just adding my voice to the issue.

Wordpress Login With Ajax, and s2 Member now conflict for non-admin users.

It is seems related to redirects.

Hope you can work together to find a solution.

http://wordpress.org/plugins/login-with-ajax/

http://wordpress.org/support/topic/redirect-not-working-for-non-admin-users

I suspect the clamour will begin to grow as more people discover the same issue…

Posted: Thursday Jun 6th, 2013 at 8:42 am #51498

Same problem ! I made some tests with different login widgets and redirection do not work. It may be the same problem with different consequences.

Posted: Thursday Jun 6th, 2013 at 8:47 am #51502
Guy B
Username: gecko_guy

It is a real pain. I have spent 2 days trying to fix it or find an alternative. I am feeling quite desperate but no help seems to be forthcoming from either developer.

I have also tried different plugins, all to no avail. I am now testing to see if I can invoke a modal located on a page that can be redirected, or from a menu link.

I guess the final answer is to go back to using the previous version of login with Ajax, but I don’t like outdated plugins.

Posted: Thursday Jun 6th, 2013 at 9:08 am #51515
lorem bolo
Username: lorembolo

Thanks to all for your answers.
Do the developers have an idea about this issue?
Thanks in advance.

Posted: Thursday Jun 6th, 2013 at 9:20 am #51521
Guy B
Username: gecko_guy

Post edited.

I am going in circles.

Why is it possible for the Admin user to log in without the endless loop, but lower levels not?

I just don’t get it.

Posted: Monday Jun 10th, 2013 at 9:59 am #51714
lorem bolo
Username: lorembolo

No news from the devs ?

Posted: Thursday Jun 27th, 2013 at 8:44 am #52676
Peter G
Username: eLunatic

s2member seem to require special handling of the login data.
no ajax login plugin seems to work with s2member so far.

but since s2member uses it’s own login-widget, maybe we need to use this, instead of the regular wp_login.php?

Posted: Friday Jun 28th, 2013 at 11:00 pm #52776
Staff Member

s2Member doesn’t do something to prevent login widgets from working. As far as I know, the login session is handled by WordPress and s2Member doesn’t interfere with it. I’ll ask Jason if a recent update may have had an undesired effect like this.

Viewing 10 replies - 1 through 10 (of 10 total)

This topic is closed to new replies. Topics with no replies for 2 weeks are closed automatically.

Old Forums (READ-ONLY): The community now lives at WordPress.org. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.