latest stable versions: v140409 (changelog)

Old Forums (READ-ONLY): The community now lives at WordPress.org. If you have an s2Member® Pro question, please use our new Support System.

Tabindex messed up on registration page

Home Forums Community Forum Tabindex messed up on registration page

Tagged: ,

This topic contains 3 replies, has 3 voices.
Last updated by  Jason (Lead Developer) 1 year, 2 months ago.

Topic Author Topic
Posted: Friday Jan 25th, 2013 at 7:50 am #39500
robert riley
Username: rriley

I’ve enabled the ‘collect first/last name during registration’ option in s2Member, however the tab order is messed up.

The first two standard fields which I believe are part of the WordPress core (username/email address) have no tabindex attributes associated with them, while the first/last name fields provided by s2member have tabindexes of 30 and 40.

The result of this is that when I fill in username and hit tab, focus correctly moves to email address. However, when I hit tab when I’m on email address, instead of moving to First Name, it shoots to the bottom and highlights the login link.

So far the only solutions I’ve been able to think of are either hacking s2member or the wordpress core to tweak tabindex attributes, which are both undesirable of course. Is there another way around this? Thanks

Bob

List Of Topic Replies

Viewing 3 replies - 1 through 3 (of 3 total)
Author Replies
Author Replies
Posted: Saturday Jan 26th, 2013 at 3:55 pm #39707
Eduan
Username: Eduan
Moderator

Hello Robert,

Yes you would have to hack WordPress/s2Member to fix this. I’ll notify Jason so that he can fix it though. :)

- Eduan

Posted: Monday Feb 4th, 2013 at 4:41 am #40591
Staff Member

Thanks for the heads up on this thread :-)

~ Investigating this. Thanks for your patience.

Posted: Monday Feb 4th, 2013 at 6:40 pm #40791
Staff Member

The issue has been identified, and s2Member® will be updated to support WordPress® v3.5+ in this regard — in the next maintenance release. In WordPress® v3.4 those two fields had tabindex values of 10 and 20. Apparently this changed in WP v3.5+.

Thanks for reporting this.

Viewing 3 replies - 1 through 3 (of 3 total)

This topic is closed to new replies. Topics with no replies for 2 weeks are closed automatically.

Old Forums (READ-ONLY): The community now lives at WordPress.org. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.