latest stable versions: v150827 (changelog)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Can't edit admin profile after setting level0

Home Forums Community Forum Can't edit admin profile after setting level0

This topic contains 7 replies, has 2 voices. Last updated by  Eduan 3 years, 11 months ago.

Topic Author Topic
Posted: Monday Jan 14th, 2013 at 11:00 am #37401


I added all the content to my video membersite.
Ready… All is :)

Then adding level 0,1 and a few ccaps for speciel “packs”.

When hitting the http://www.domain/wp-admin I get “You do not have enough rights to access this page”
Okay… Taking off the WP-Protection… Still same msg? Hmmm
Trying to edit my admin profile : you do not have enough rights to access ….. ??? Kebab! :-(

What tick did I miss?
Do I have to set ALL ACCESS levels and CCAPS on admin profile just to login in and also to edit admin page?
Maybe I should pay myself via paypal?? :-)

Help please
And in advance… Thanks!

List Of Topic Replies

Viewing 7 replies - 1 through 7 (of 7 total)
Author Replies
Author Replies
Posted: Tuesday Jan 15th, 2013 at 9:49 pm #37692
Username: Eduan

Hello Peter,

Can you be absolutely sure that the account you’re trying to use to access those pages/URLs is an admin account?

s2Member will never block anything to the admin user, so this means either the user you’re logging in as is not an admin or your WordPress installation became corrupted somehow.

Also, what do you mean with “WP-Protection”? s2Member has nothing by that name.

– Eduan

Posted: Wednesday Jan 16th, 2013 at 5:36 am #37711

Hi Eduan,

Thanks for your answer.

This is what happend.
After setting up the entire “structure” of my site and configuring S2member with Paypal and all…
I added two user-fields.
I did some moving around with the pages, added some more featured video (using a nice theme from Ruven (Polyon)
Then it happend… The keept saying “You do not have enough permission….”
After login and if I click the “WP Dashboard” for admin. If I click “Profile” …and so
But I can always get in by opening www, or any other url that I might remember in the admin section!

Here is what I tried to find the “bug”
I created a second account and gave it admin rights – Tried to edit the “admin” account – Nope
I could however edit the new “Peter” account (see below)
I disabled the S2 rescriction/security – Nope
I disabled all plugins – Nope ??? (I have for a start a minimum of plugins to give S2 some space and avoid conflict)
I disable all plugins and S2 – Nope
I activated the standard theme from WP (Twenty Eleven) – Nope

The problem persist even without any plugins – So it’s maybe not S2 problem??
I compared all my files against another WP installation to see if some was missing or diffrent – Nope all is in place??
The only thing I can’t compare is the DB – Where I expect the error to be?
After reactivating the S2 – It’s ALL OVER FROM THE BEGINNING!! (Almost)
Paypal settings lost :-( – Re-done

But I noticed that my user fields (2) also was gone – I created them again but maybe I gave them a different name? – So now when logged in as “Peter” I can edit all fields but one (an OLD field) is showing but is greyed out and is EMPTY??? I still can’t edit the “admin” account or see the profile – The problem is persistent.

Strange thing!?

Have a great day


Posted: Thursday Jan 17th, 2013 at 5:22 pm #37950
Username: Eduan

Hello Peter,

Well this definitely sounds like a problem with your DB, your user DB most probably, not s2Member or your plugins or themes or anything.

I’m afraid you will probably have to reinstall WordPress from zero. I suggest you make a full backup of your current website and DB, and start from zero, see if the problem happens again.

If it does, then it means that one of the plugins or your theme are breaking the admin user (user ID 0 or 1) somehow.

– Eduan

Posted: Friday Jan 18th, 2013 at 5:05 am #38017

Hello Eduan,

Thanks for your replies time and input.
I was afraid you would say / suggest that!… It’s a lot of work! Hmmm
Maybe a DB repair tool? someone have a handy tool ??

Anyway … I will live with the “pain” for a while and on a rainy day with no other projects …redo the installation

Thanks again


Posted: Saturday Jan 19th, 2013 at 3:31 pm #38320
Username: Eduan

No problem, good luck. :)

Posted: Monday Feb 4th, 2013 at 6:24 am #40616

Ahhhh a new install is heavy work…

Anyway … before I got to it… some new users did signup for membership :)

But s2Member did NOT get the message??
I had to manual add the users info and give them level 1 Hmmm
Did check my Paypal setting 100 times… All seems in place and I have a Business account?

This is what one user said the error was on her screen:
ERROR: Unable to verify $_POST vars. Please contact Support for assistance.

Anyone has a clue?

Posted: Wednesday Feb 6th, 2013 at 2:59 pm #40921
Username: Eduan

Hello Peter,

Could you please post the URL of your website and a full copy of the shortcode the user used when he got that message?

– Eduan

Viewing 7 replies - 1 through 7 (of 7 total)

This topic is closed to new replies. Topics with no replies for 2 weeks are closed automatically.

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.