latest stable versions: v150827 (changelog)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Security Badge not showing?

Home Forums Community Forum Security Badge not showing?

This topic contains 42 replies, has 14 voices. Last updated by  Cristián Lávaque 3 years, 4 months ago.

Page 2 Of Topic Replies

Viewing 17 replies - 26 through 42 (of 42 total)
Author Replies
Author Replies
Posted: Thursday Apr 11th, 2013 at 5:24 am #47163

Yes, after you finished debugging, remove them from the server, please. You can download a copy of the files before removing them from the server, of course.

Posted: Thursday Apr 11th, 2013 at 1:25 pm #47209
CC SHambres
Username: Chevaune

No change unfortunately

Posted: Friday Apr 12th, 2013 at 12:27 am #47264

Hi you all,

I had/have the same issue and in my case (I have a lot of plugins on our site) I’ve narrow it down to a plugin by Boone Gorges – Invite Anyone plugin… It just had an update and that makes the s2member badge disapear… wonder what else it breaks…

Unfortunately I really need both, s2member and invite anyone plugins… might roll back to a previous Invite Anyone version.

I’ll post this to the other plugin’s support forum too…

Thanks for the great plugin!!



If I inactivate Invite Anyone and delete and re-install the new version, the s2member security check won’t get compromised… and the s2member badge keeps on shinin’

Strange… Anyhow… I’m good for now … might worth investigating though…

Posted: Saturday Apr 13th, 2013 at 7:55 am #47413

My security Budge happens to be at risk even if I checked almost three times that all the security aspects were ok (I have also changed the security in wp-config.php keys to be sure). I have refreshed thousands of time my browser but still the badge says “not yet verified” and the security is at risk (0 when click the link to status report). I can say that the badge was ok and appeared correctly on my web sites prior to s2member plugin update, but I did not notice the precise moment when the website stopped to be secure. Can anybody help me please?
Thanks in advance,

Posted: Saturday Apr 13th, 2013 at 4:32 pm #47431

Exact same thing as Salvatore’s happened to me. Badge was working great and then stopped being “verified”. Test gives 0 and clicking in the badge shows NO condition is met, even though I haven’t changed a thing and all settings are according to instructions.

I posted this issue in another thread but seems like I didn’t subscribed to it and ca’t find it now.

Posted: Saturday Apr 20th, 2013 at 8:16 pm #48023
CC SHambres
Username: Chevaune

Still no solution to this

Posted: Monday Apr 22nd, 2013 at 10:32 pm #48144

Please make sure that only the .htaccess file is left in the /wp-content/plugins/s2member-logs/ directory. Any log file or archive of them, will cause the badge to not validate.

Posted: Tuesday Apr 23rd, 2013 at 3:32 am #48157

I had the same thing happen here, now it’s solved. I don’t know if this goes for anyone else.
I DL the file s2-server-scanner.php and ran it.
One of the errors shown was:
[ERROR] cURL Extension / Or fopen() URL

One or more HTTP connection tests failed against localhost.
Cannot connect to self over HTTP — possible DNS resolution issue.
Can’t connect to:

In order to run s2Member®, your installation of PHP needs one of the following…
• Either the cURL extension for remote communication via PHP (plus the OpenSSL extension for PHP).
• Or, set: allow_url_fopen = on in your php.ini file (and enable the OpenSSL extension for PHP).
Please consult with your web hosting company about this message.
I sent this errormessage to my host and they fixed the problem.
The badge is back again.. ;)

Posted: Friday Apr 26th, 2013 at 3:27 am #48437

Thanks Cristián, that solved the issue. There were some files in that folder, I deleted them from FTP and the badge started working again :)

Posted: Friday Apr 26th, 2013 at 5:16 am #48455

Great! Thanks for the update. :)

Posted: Sunday Apr 28th, 2013 at 3:02 pm #48628
CC SHambres
Username: Chevaune

Awesome. It is now working for me also.

Posted: Sunday Aug 4th, 2013 at 9:01 am #55060

I had the same thing since I updated to WordPress 3.6 and updated the latest version of S2Member.
But thanks to Cristián, it works now. I had over 350Mb logs in there. Perhaps you could mention this in the requirements because resetting the logs does not erase the other ones, like paypal logs, for instance.
I actually do not understand where they come from since logs where turned off for years.

Anyway, it works again, thanks Cristián! ;-)

Posted: Monday Aug 5th, 2013 at 5:36 am #55216

No problem! :)

The badge article does mention that: Knowledge Base » s2Member® Security Badges

any existing log files from previous debugging efforts MUST be deleted

But I’ll see where else we can mention it to make it more obvious. Thanks!

Posted: Tuesday Aug 13th, 2013 at 7:20 pm #55706
Colten Fry
Username: coltenfry

Says my site is secure, but will not show up with the short code

[s2Member-Security-Badge v="1" /]
Posted: Tuesday Aug 13th, 2013 at 10:40 pm #55714

Colten, some months ago another user had a similar problem, and this is what Jason said:

This could happen if we are unable to reach the API for some reason.

@file_get_contents(rtrim($_g['site_url'], '/').'/?s2member_s_badge_status=1')) === '1'

So for instance if their site is down; or is refusing connections for some reason; or if the resulting badge status says something other than just 1. (i.e. there is a PHP error or something like that also).

And the user confirmed he did have a server problem. Maybe you’d want to check that. Also try these: Knowledge Base » Common Troubleshooting Tips

I hope that helps. :)

Posted: Wednesday Aug 14th, 2013 at 12:10 am #55721
Colten Fry
Username: coltenfry


Thank you for the prompt reply. I figured it out… I installed the server scan and everything checked out fine… I then deactivated one plugin at a time and found a conflicting plugin.

I re-installed the plugin and my badge now works!

Thanks again for the quick reply!

Posted: Wednesday Aug 14th, 2013 at 12:15 am #55722

Excellent! Thanks for the update. :)

Viewing 17 replies - 26 through 42 (of 42 total)

This topic is closed to new replies. Topics with no replies for 2 weeks are closed automatically.

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.