latest stable versions: v150827 (changelog)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

security badge not updated

Home Forums Community Forum security badge not updated

This topic contains 15 replies, has 4 voices. Last updated by  Cristián Lávaque 3 years, 10 months ago.

Topic Author Topic
Posted: Thursday Feb 14th, 2013 at 2:18 am #41679

I followed all the steps jason described. Still the badge shows “not verified” (in the dashboard).
Also, no matter what shortcode I try, the badge won’t show on posts or pages…

Am I overlooking something?

List Of Topic Replies

Viewing 15 replies - 1 through 15 (of 15 total)
Author Replies
Author Replies
Posted: Friday Feb 15th, 2013 at 5:55 am #41821
Staff Member

Thanks for your inquiry. ~ We appreciate your patience :-)

If you’d like us to review your configuration to ensure it is secure, please submit a Dashboard login here. See: s2Member® » Private Contact Form. We can tell you why your Badge Status API is failing verification.

Posted: Friday Feb 15th, 2013 at 9:31 am #41877

I cannot find that Private Contact Form jason. Am I overlooking something?
** moments later **
Found it!

Posted: Friday Feb 15th, 2013 at 6:59 pm #41912
Staff Member

Details received. Thank you!

~ Investigating now.

Posted: Friday Feb 15th, 2013 at 7:08 pm #41914
Staff Member

Thanks for your patience.

Your configuration looks good. You just need to enable the Badge Status API please.

See: Knowledge Base » s2Member® Security Badges
See: Dashboard -› s2Member® -› General Options -› Security Badge

Posted: Saturday Feb 16th, 2013 at 1:10 am #41927

Duuuhhh, OMG I feel quite stupid. I totally overlooked that one. Tx for your time.

Posted: Tuesday Feb 26th, 2013 at 10:17 am #43242

Hi Jason,

I’m sorry to bug this thread but the exact same thing is happening in my sites, although I do have the API enabled and the test gives 1. In dashboard the security bad shows “not verified” and it is not visible in any of my pages. To worsen things up, the file badge.php is taking sseveral seconds to load, increasing my website load time quite a bit.

I’ve seen other users who seem to be having the same issue (i.e. and – where I posted a few days ago). Any idea what might be happening?

Posted: Wednesday Feb 27th, 2013 at 7:56 am #43297

Hi Mary.

Could you try the troubleshooting tips in this article? Knowledge Base » Common Troubleshooting Tips

I hope that helps. :)

Posted: Wednesday Feb 27th, 2013 at 9:45 am #43319

Hi Cristián, thanks for your answer.

I own a network and use s2member in two of my sites, but they’re live and I cannot risk breaking something by following the steps you mentioned, so I tried it in my main blog which is mostly empty.

I setup s2member in that blog and reproduced the error. After setting up the membership options page, generating a security encription key, enabling the security badge API and inserting the shortcode, the badge shown in the dashboard says “not yet validated”. I navigate to my site and the badge is not there, but the code is:

<a href="" onclick="';', '_popup', 'width=770,height=720,left='+((screen.width/2)-(770/2))+',screenX='+((screen.width/2)-(770/2))+',top='+((screen.height/2)-(720/2))+',screenY='+((screen.height/2)-(720/2))+',location=0,menubar=0,toolbar=0,scrollbars=0,resizable=1'); return false;" title="s2Member&reg;"><img src="//;" style="border:0;" alt="s2Member&reg;" title="s2Member&reg; ( Seguridad para WordPress&reg; )" /></a>

The exact same thing happens in my other two sites. I haven’t changed anything on them, not the team, not a plugin, nothing. And my WP installation and all plugins are up to date (including s2member). Sadly I cannot trace the incident back so I don’t know exactly when this started happening, I adventure myself to believing it was after the latest WP update as another user said in one of the forum threads I mentioned.

I followed these troubleshooting steps on my main blog with no luck:
– deactivated all plugins
– changed theme (was twentytwelve, switched to thesis 1.85 which is the one in my other sites)
– everything is setup accordingly to your indications (and, as I said, I hadn’t changed any of that when the problem started), plus, the test throws “1” (on my three websites) meaning everything is well configured
– uploaded the server test file and on loading it on my browser I get only one warning:

[WARNING] Plugin Directory Checksum (s2member)
Although NOT required, s2Member® recommends that you reinstall the following plugin directory: /home/content/62/7668362/html/wp-content/plugins/s2member. The checksum for this plugin directory (ef10b8631d55ef2ee0a6eae6e872e0a0), does NOT match up with the official release of this plugin (9dbe1c5290616e7dd2d2ee9d44a482cf). An invalid checksum can be caused by an incomplete set of files. Or, by files that should NOT appear in this directory. Or, by corrupted files in this directory. Reinstalling the official release of this plugin should correct this issue.

So, I guess this needs to be done and hopefully that will solve the problem (Id on’t know how that happened because I’ve always updated s2member from my dahsboard, but anyhoo).

Before I reinstall s2member I rather ask, shoudl I just download installation files from my account and upload them to where they should go (i.e. where they are right now) using FileZilla? Would it break current use of the plugin? I mean, my sites are live and I don’t want my subscribers to experience any inconvenience after I reainstall, nor I want to loose any of the configuration informations…

So what’s the best modus operandi to follow here? (and thanks a lot for taking up my case)

Posted: Wednesday Feb 27th, 2013 at 6:04 pm #43349

Right, it’d be best to reupload that directory to remove that warning, which may be causing the badge problem.

What you can do to avoid trouble as little as possible is to upload with FileZilla the folder but with another name, so it doesn’t replace the existing s2Member. When the upload is complete, change the current s2Member’s folder name adding a suffix like “s2member-old”, and name the new folder you just uploaded as “s2member”. This will switch one with the other without a downtime.

Fiirst, though, make sure you have the deactivation safeguards enabled. [hilite path]Dashboard -› s2Member® -› General Options -› Deactivation Safeguards[/hilite]

I hope that helps. :)

Posted: Thursday Feb 28th, 2013 at 5:35 am #43388

Hi Cristián.

I did as instructed, but the problem is still there (the badge does not appear on any page, and it appears as “Not yet verified” in the dashboard, even though the test gives 1, the same div is inserted into all pages). I had to upload the plugin directory twice until the php check was OK.

Anything else I need to do?

Posted: Thursday Feb 28th, 2013 at 7:30 am #43396

Glad you fixed the warning. :)

Regarding the badge, could you send me your site’s info so I take a look? Please let me know when you sent it. Thanks! s2Member® » Private Contact Form

Posted: Saturday Mar 2nd, 2013 at 9:22 am #43603

Hi Cristián,

I’ve just sent what you asked through the private contact form. I gave you access to the main blog of my network, which is not live so you can do any testing you need to.

I’ll be waiting for any news on this. Thanks a lot, really.

Posted: Tuesday Mar 5th, 2013 at 8:07 am #43761

Thanks for the info, Mary, I got your email. I couldn’t login to the FTP to look at wp-config.php to verify everything’s correct there, though. Could you resend the FTP info? I’m replying to your email so you can reply back to it instead of submitting a new contact form.

Posted: Tuesday Mar 5th, 2013 at 10:49 am #43787

Just replied to your email!

Posted: Friday Mar 8th, 2013 at 3:37 am #44034

Mary Grisolia said:

I’m so sorry that you’re having trouble with logging in, I know you’re busy and I appreciate you taking the time to look into my website.
My sites are hosted on GoDaddy and it seems that they’re having issues with some of their servers, including the one my websites are hosted. This has been going on since saturday and they said they don’t know when the issue will be resolved. The websites come up and down intermitently.

In the meantime, I created an account in Hostgator and moved some of websites over there to do some testing. Turns out the badge works perfect in that (Hostgator) server. One difference I observed with setup in Hostgator compared to GoDaddy is that an extra line in .htaccess was required for PHP files to work properly:

# Use PHP 5.3
AddType application/x-httpd-php53 .php

Do you think this may have something to do with my badge issue?
I’m waiting for GoDaddy’s servers to come back to normal so I can log in to my account and add this line to my .htaccess file there. Once I do that I’ll let you know if the badge issue was solved or not.

Thanks and sorry again.
Have a great day!

Mary Grisolia said:

I wanted to let you know that FTP access has been reestablished, but I just cjecked this morning and the badge is working again! Yesterday I modified the .htaccess using the line of code I told you about but didn’t see a change at that moment. Today, it works :)
Either it was that (although I thought changes in .htaccess took place immediatly, and they didn’t in this case), or GoDaddy did something on their side and the badge issue was related to a hosting issue.
In any case, I’m very sorry to have bothered you with this as this wasn’t s2Member’s fault.
Thanks again, and please let me know if I can delete the user account I created for you.

Hey, that’s great news! Thanks for the update. I’m very glad it’s working for you again. :)

Sure, go ahead and remove the account, please, I don’t need to login now.

Viewing 15 replies - 1 through 15 (of 15 total)

This topic is closed to new replies. Topics with no replies for 2 weeks are closed automatically.

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.