latest stable versions: v150827 (changelog)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Unable to Log In as Admin

Home Forums Community Forum Unable to Log In as Admin

This topic contains 3 replies, has 2 voices. Last updated by  Randy King 3 years, 4 months ago.

Topic Author Topic
Posted: Friday Aug 16th, 2013 at 1:19 am #55989
Joe White
Username: jmwfvl

I just installed S2Member on my website today, first time ever using it. I went completely through the Getting Started material, watched the video, and went back through Getting Started and used it as a reference for each step of setting up S2M. I’m pretty sure I followed all instructions carefully.

Everything was looking very good after a few hours. Member rules were set, everything seemed to be working.

I needed to set up pages for Restricted Access, so that visitors will have to pay to see those pages.

After updating several Restricted Access pages and checking to see that they worked properly, even going through to PayPal payment, I tried to log out of my WordPress Admin account so I could see what the site looks like to a visitor. I was unable to log out, I got redirected to the Member Options page. I tried logging out several times.

I finally closed my browser and restarted it. Now, when I go to the website, I can click on “Login Welcome”

(which is the WordPress permalink I don’t use “www.” for this site.)

and it redirects me to the Member Options page.

If I try to go to

the browser is redirected to

which displays the website without menu bars – the menus appear as a list of plain words on the left. It’s the Member Options page, but there are no options to change — before I closed the browser, the page showed me those options, change e-mail, etc. Now, it just reads “Welcome, Gold Member!” Which is what I edited it to read.

But I’m still not logged in. I never get to the wp-admin log in page, never get to any place where I can type in my username and password.

I have gone through and attempted the Support KB suggestions for fixing this, nothing applied to this situation.

HELP!! Please! I spent about 8 hours setting up S2Member, I don’t want to delete the whole WordPress install and start from scratch.

Thanks in advance.

List Of Topic Replies

Viewing 3 replies - 1 through 3 (of 3 total)
Author Replies
Author Replies
Posted: Monday Aug 19th, 2013 at 4:26 pm #56181
Randy King
Username: RandyKing


Are you sure that the user you set up and were using was a WordPress administrator? It sounds like NOT, it sounds like that user’s role got set to something other than Administrator, which would explain what’s going on here.

So you can easily disable s2Member temporarily. Do the following:

1. Use FTP to get into your site.

2. Traverse the directory structure until you get to a path that will end in exactly the following:


3. In that folder, RENAME the folder “s2Member” to something like “s2Member-HOLD”

4. Now log in to your site – s2Member will be “gone” as far as your site is concerned.

5. Fix the problem – sounds like you need to check the ROLE of the person you are logging in as. It MUST be “Administrator”.

If you are looking to test what happens when you are NOT an administrator or not logged in…

Did you know that when you are logged in as your site administrator that you are the all-seeing, all-knowing god of the site? You CANNOT TEST what non-members will see because you have full access to everything; s2Member grants access to the world to you.

This is why I have installed Firefox, Chrome, Opera, Safari, and Internet Explorer on my computer. I develop in Firefox, then I open Chrome to access the page as a non-member who is not logged in.

That last bit is IMPORTANT – develop in browser “A” and test in browser “B” – DO NOT USE TWO INSTANCES OF THE SAME BROWSER; e.g., do NOT open two Firefox browsers – they SHARE cookies, cache, etc., and you will still be logged in as administrator in that second browser even though it’s a separate instance.


Posted: Monday Aug 26th, 2013 at 4:13 pm #58701
Joe White
Username: jmwfvl


Thanks for the advice. I was logged in as administrator. I developed the site in Chrome, and tested it in Firefox and Opera. I am familiar with WordPress administrator rights, I have put together several simple WP sites in the past, this is by far the biggest and most complex I have set up.

Again, I appreciate your input. However, as I had a deadline for this site, I ended up copying all my pages to a backup folder in my main account on my host, deleting WP, re-installing WP and starting almost from scratch. Spent a lot of extra hours, but got finished on time.

Never did figure out exactly what happened, it may have been with the default S2M login page.


Posted: Monday Aug 26th, 2013 at 9:39 pm #58707
Randy King
Username: RandyKing

Joe – I have done exactly that as well, and have reached the same conclusion: something must have barffed during install/setup/whatever. Glad you got it going!


Viewing 3 replies - 1 through 3 (of 3 total)

This topic is closed to new replies. Topics with no replies for 2 weeks are closed automatically.

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.