latest stable versions: v150827 (changelog)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Registration form processing (503 error)

Home Forums Community Forum Registration form processing (503 error)

This topic contains 5 replies, has 3 voices. Last updated by  Ken Smith 3 years, 3 months ago.

Topic Author Topic
Posted: Sunday Sep 1st, 2013 at 11:05 pm #58958

Hi there. I’ve never actually written to a forum like this before, so please bear with me.

I’ve been using s2Member on a client’s website for several months now. It’s a great plugin.

However, we’ve had a recent issue with membership registrations not processing and registrants getting a “503: Service Temporarily Unavailable” error. “The server cannot process your request because of maintenance downtime or capacity issues. Please try again later.”

This is not related to login issues, or too many IP addresses as I’ve seen several others mention on the forums. People can log in fine. And we can add a new user manually, and then they can login fine.

It’s just the submission of the registration form that is sporadically giving this 503 error messages.

Strangely enough, in several cases, when I’ve replicated the error, if I refresh the browser on the 503 error page (specifically in Chrome) the page goes through and processes. But this doesn’t work in Firefox or Safari. Sporadic in IE.

This issue started sometime in the past 6 days, because on Aug. 26, 2013, we processed registrations with no problem.

There is no issue with PayPal or redirection. Everything works perfectly until the user tries to submit their registration form. Then the error. PayPal is processing all of their payments, which can make for an unhappy user to pay, yet then not be able to finish the registration process.

I have tested with all other plugins deactivated and the same sporadic 503 pops up randomly. And I am running the latest versions of the free s2member plugin and wordpress.

I’m basically trying to figure out if this really could be an s2Member issue, or if the shared hosting server my client’s site is on is basically having some issues. I’m guessing the latter, but I wanted to throw this out there in case someone might know of something that I don’t.


List Of Topic Replies

Viewing 5 replies - 1 through 5 (of 5 total)
Author Replies
Author Replies
Posted: Monday Sep 2nd, 2013 at 11:18 pm #58996
Username: skiser

Ken – I am having the same issue. My customers are receiving the same error when trying to register. Registration has worked fine on our site for at least six months and this error just surfaced in the last couple of weeks. After contacting my host they informed me that there was no issue on their end. I am now in the process of working through the plugins and theme to see if there are any conflicts…


Posted: Monday Sep 2nd, 2013 at 11:59 pm #58997

Hi Susan.

I’ve run across something that might be part of the issue.
And I’m sure this is an issue that has come up with the latest upgrade of s2Member.

I downloaded the S2 member server scanner file from the troubleshooting web page. I installed the scanner.php file and ran the scan. It showed everything was fine except that our default memory level for WordPress was only 40 mb. S2 member recommend at least 64 mb.

There were instructions in how to change this in the wp-config.php file. So I did that. I actually upped the memory level to 96mb. Reran the scan and everything about the server config checks out.

I’ve tested several times on different browsers since that change and I have not had a failed attempt yet.

I’m hoping that this is the issue. I was still having the error when submitting the form from iPad, but it was working in all major browsers on desktop at least.

If you get any other intel on this, please let me know.


Posted: Tuesday Sep 3rd, 2013 at 4:27 am #59008

I (or my users) faced this error countless times over the last years. I would say it happens on every 10th to 20th registration.
Usually a couple hours later it’s fine again. I rather thought that it’s related to Paypal servers being down. I’m not kidding, but at least here in Europe the Paypal API servers don’t seen to have more than 95% uptime.

It’s like in your Paypal account – clicking on stuff like search payments or last month sales report, takes 10-20 seconds for Paypal to handle out. It’s insane how crappy Paypal servers are in relation to the amount they are charging.

Posted: Tuesday Sep 3rd, 2013 at 10:48 pm #59053
Username: skiser

Glad your registration form is working! Thanks for the suggestion to upgrade the memory. I ran the server scanner and then increased the memory. The scanner now shows everything is working well. In addition, I updated my theme and tried the default WP themes. However, I am still getting the 503 error almost every time and with every browser. Next I’ll test the plugins. So the search for an answer continues…


Posted: Thursday Sep 12th, 2013 at 2:47 pm #59497

Hi Susan….

Have you had any new luck in getting your issue resolved?

After some good testing on my end, we have backslid is seems like. We are sporadically getting the 503 error again. Not every time, and if you get it once, then refresh your browser and resubmit the form, it usually goes through, but we’re still getting it.

Just checking to see if you had made any headway.


Viewing 5 replies - 1 through 5 (of 5 total)

This topic is closed to new replies. Topics with no replies for 2 weeks are closed automatically.

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.