latest stable versions: v150827 (changelog)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Registration issues

Home Forums Community Forum Registration issues

This topic contains 3 replies, has 3 voices. Last updated by  Cristián Lávaque 4 years, 7 months ago.

Topic Author Topic
Posted: Monday May 28th, 2012 at 1:50 pm #14830
Username: donna2012

I am having an issue with the software, where some clients after they pay (using paypal pro and taking the payments directly on our site) they are setup as a subscriber instead of level 1. Seems to be random and cannot figure out why some are being setup correctly and others are not. It has happend twice now the most recent was this morning. Can you give me some ideas of where to check? I have looked at the logs in wp-content/plugins/s2 logs and paypal seems to be putting the same information on each customer but does not seem to make it back to S2member to setup the customer with the proper permissions.

Appreciate your help!

List Of Topic Replies

Viewing 3 replies - 1 through 3 (of 3 total)
Author Replies
Author Replies
Posted: Tuesday May 29th, 2012 at 4:00 am #14857
Raam Dev
Username: Raam
Staff Member


This sounds like there might be an issue with the IPN communication between PayPal and your server. The best route of diagnosis will be through looking at the log files and attempting to determine which IPN messages are not being received.

If I’m not mistaken, I believe PayPal has a dashboard where you can see which IPN messages were sent and whether they were successfully received. You should also be able to resend specific IPN messages from that dashboard.

Posted: Tuesday May 29th, 2012 at 10:27 am #14873
Username: donna2012

When I go to paypal it says the IPN feature is disabled. How is that even possible? S2member should not work at all if the IPN is turned off should it? So theoretically assuming that it is possible for S2member to work without the IPN turned on, then all I have to do is enter the IPN URL and turn the feature on, correct?

Posted: Wednesday May 30th, 2012 at 6:18 am #14910

It’d be good that you contact PayPal support asking about enabling that, then. You really need it for the PayPal Pro integration to work properly with s2Member.

From [hilite path]Dashboard -› s2Member® -› PayPal® Options -› PayPal® IPN Integration -> More info[/hilite]

With PayPal® Pro integration you absolutely MUST set an IPN URL inside your PayPal® account. PayPal® Pro integration does NOT allow the IPN location to be overridden on a transaction basis.

Viewing 3 replies - 1 through 3 (of 3 total)

This topic is closed to new replies. Topics with no replies for 2 weeks are closed automatically.

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.