latest stable versions: v150827 (changelog)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

About: Gabor Ringhoffer

Sorry, I've not written a description yet. I'll get to it soon!

Topics I'm Subscribed To

Viewing topic 1 (of 1 total)
Topic Count Last Reply
Security Badge not showing? 1 2

By:  Dan Cundy in: Community Forum

voices: 14
replies: 42

3 years, 4 months ago  Cristián Lávaque

Viewing topic 1 (of 1 total)

My Latest Replies (From Various Topics)

Viewing 5 replies - 1 through 5 (of 5 total)
Author Replies
Author Replies
Posted: Friday Feb 8th, 2013 at 3:56 am #41182

Quick update. My admin area has displayed an available update for S2Member. I did the update and the Badge is now displayed.

I am not sure what was the issue finally, but your update seems to me that it has fixed this issue.

I will take some time to test the whole functionality, and if all ok, I will consider to become paid member for your plugin.


Posted: Friday Feb 8th, 2013 at 3:52 am #41181

1. Is your Badge Status API enabled?

See: s2Member -> General Options -> Security Badge -> Badge Status API

Gabor: It is enabled, and it was enabled since the first installation.

2. Does your /wp-config.php file have all of these configuration values?

(each of these MUST be at least 60 chars, and must NOT contain: ‘unique phrase’)

Gabor: Looks ok to me.

3. Have you created a Security Encryption Key for your s2Member installation?

See: s2Member -> General Options -> Security Encryption Key
(this MUST be at least 60 chars as well)

Gabor: Yes, Key is created since the first installation.

4. Does your /wp-config.php file have both of these configuration values?

DB_USER and DB_PASSWORD. These must be filled in, and must NOT be the same value.

Gabor: They are there and they are not the same

5. Have you configured your Unique IP Restriction Options yet?

See: s2Member -> Restriction Options -> Unique IP Restrictions
(this must NOT be set to: infinite)

Gabor: I have set this to Infinite because some users whos ISP change IP frequently got locked out. I have now changed it to Allow 100 Different IP. Issue still remain. No badge is displayed.

6. Have you configured your Brute Force IP Restrictions yet?

See: s2Member -> Restriction Options -> Brute Force IP Restrictions
(this must NOT be set to: infinite)

Gabor: It was set to Allow 5 failed login attempts.

7. If you visit this link on your WordPress® installation, you should get a plain text file that contains only a single value of: 1 (indicating your site is in the green w/s2Member®). If you don’t, one of the above is the likely cause.

This test installation is running WordPress® v3.6-alpha and the latest version of s2Member®.

Now look at your installation:

Gabor: Result is 1 in my browser, but still no badge displayed.
The URL of my site is:
Posted: Thursday Feb 7th, 2013 at 3:37 am #41017

Hi Eduan,

Quick update.

I have changed hosting provider so I decided to reinstall the whole thing on the new server.

Unfortunately, issue is still there. The badge does not display on the bottom of my page as it was before.


Posted: Monday Feb 4th, 2013 at 3:41 pm #40783

Hi Eduan,

I did all step you have requested.

I have latest WordPress and Latest S2 member plugin.

Safety First -> Set correctly
Conflicting Plugins -> I have only one plugin, which manage the maintenance mode. It was there before, when S2 plugin correctly displayed the badge. Anyhow, I have disabled it, still not fixed the issue.
Conflicting Theme -> Issue remain while switched to default theme. No badge displayed.
User Error -> Not sure about what should I look for. There is no error, not even in the error_log file.
Server Configuration -> Your test file come with all green and message like: You passed on all of these scans :-)
Outdated Installation -> All is up to date.
Corrupt or Missing Files -> All site work correctly, nothing is corrupted. I can delete the plugin and install it again, if you tell me how to save and import all settings regarding S2 config.
Testing in a Development Environment -> I need some time to do another installation.

For your info: Badge was displayed correctly until I upgraded lately WordPress. Nothing else was changed. No plugin was installed or removed. Since WordPress upgrade, no matter what I do, S2 member don’t display badge anymore. The funny thing is that I was ready to upgrade to pro when I saw this issue, so even if your script coming back with all green status, I am not sure if S2 member correctly working or not, if members are managed correctly or not, so I hope this will be fixed or at least I hope that we will debug where the issue is.

Let me know if you need anything else.


Posted: Sunday Feb 3rd, 2013 at 7:35 am #40547


I have noticed the exact same issue. As far I know, this happened after WordPress update.

No matter what I am doing and how I am configuring S2Members, the badge do not show up anymore.

Anyone, any idea where to look for solution?

Viewing 5 replies - 1 through 5 (of 5 total)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.