latest stable versions: v150827 (changelog)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Re-direct potential subscribers to membership

Home Forums Community Forum Re-direct potential subscribers to membership

This topic contains 11 replies, has 5 voices. Last updated by  Jason (Lead Developer) 4 years, 10 months ago.

Topic Author Topic
Posted: Sunday Mar 4th, 2012 at 5:23 pm #7236

I have page restriction on three pages of my site. When a non registered customer clicks on any of the restricted pages it directs them to a 404 page not found. I want them to be directed to the membership options page. I’ve looked through and can’t seem to find how to do this.

List Of Topic Replies

Viewing 11 replies - 1 through 11 (of 11 total)
Author Replies
Author Replies
Posted: Monday Mar 5th, 2012 at 10:07 am #7338
Username: cassel

When a visitor tries to access a restricted page, it should automatically be redirected to your Membership option page. Did you set one up? If so, make sure it is indicated under the General Option > Membership Option Page. Use the pull down list of pages you have made and choose which one will be your Membership Option page (even if it is not called like that).

Posted: Monday Mar 5th, 2012 at 4:39 pm #7355

I have done all of what you mentioned. I already created the membership options page. I checked to make sure the page permalink was correct, which it is. Like you said, it should be directing people to the membership options page when the click on a restricted area of the site. However, it isn’t happening. I don’t know where else to look.

Posted: Tuesday Mar 6th, 2012 at 4:23 am #7426
Staff Member

Thanks for your inquiry.

You said it’s returning a 404 error.
What URL appears in your address bar when this occurs?
Is it possible that another plugin is conflicting? Have you tried with all other plugins disabled?

Posted: Tuesday Mar 6th, 2012 at 4:25 am #7427

Hello John.

Could you post a link to the page you set for the Membership Options and a page that you protected?

Also a screenshot of your panel for the Membership Options Page setting, please.
[hilite path]Dashboard -› s2Member® -› General Options -› Membership Options Page[/hilite]


Posted: Tuesday Mar 6th, 2012 at 3:50 pm #7499

I have three protected pages. When I click on “trading course” the url is

When I click on the other two (Basic member and Premium member) their respective url’s show in the address bar.

Membership options page link:

“Trading Course” tab link (protected)

“Basic member” tab link:

“Premium member” tab link:

Posted: Tuesday Mar 6th, 2012 at 10:55 pm #7512
Raam Dev
Username: Raam
Staff Member

Hi John,

Did you create a page with the permalink /log-in/? If not, you should probably be using

Did you create pages with the permalinks /basic-members-area/ and /full-members-area/ and then restrict those pages in Dashboard -› s2Member® -› Restriction Options -› Page Access Restrictions?

Also, have you tried disabling s2Member and accessing those pages? If you still receive 404 errors even after disabling s2Member, then you may have an issue with your theme or with your permalinks.

Posted: Tuesday Mar 6th, 2012 at 11:40 pm #7522

I can access the pages when logged in so I know it’s not the permalinks. They work. I created the pages mentioned above and then restricted access based on assigned membership levels. Thanks for the suggestions but nothing is working thus far. I need this one issue worked out and then I can go live with my site. Very frustrating.

Posted: Wednesday Mar 7th, 2012 at 12:51 am #7525

Thanks, John.

I remembered a similar problem in the past and searched for the forum conversation on it. Please see if this post by Jason helps:

s2Member handles redirections to the Membership Options Page in the same fashion, even on a Multisite Network installation. All requests that are denied access, get redirected to the Membership Options Page that has been configured by the site owner, for that particular Blog on the Network.

If your theme is producing Not Found messages, here are some things I would check on.

1. Does your Membership Options Page exist?
2. Do you have any other plugins that are forcing redirections that may conflict with s2Member?
3. Have you enabled s2Member's Alternative View Restrictions? (did you set them to All?)

When s2Member's Alternative View Restrictions are set to "All", all protected content is excluded from public view; including any listings that would normally be displayed in category archive views. In some themes, this can result in your theme producing a Not Found message, because there are no results to display in that category archive (i.e.

In other words, instead of saying " there are no items in this category ", some themes will simply say " Not Found ". You can either modify your theme to display the message you prefer, or turn s2Member's Alternative View Restrictions off.

Or, you could work on making navigation menus within your site more dynamic, so that category archives which are unavailable to the public, are not displayed, or are redirected to the Membership Options Page.

Another thing that might help. In cases where you are protecting all content within a Category Archive, if you protect the entire Category with s2Member, then s2Member will simply redirect all requests to that Archive, to your Membership Options Page; and that way the "Not Found" message being introduced by your theme, would never be displayed. So for example, you might try protecting this entire Category, instead of each Post within it.

Please let us know if this problem continues; we'll do everything we can to assist you.

Posted: Wednesday Mar 7th, 2012 at 9:14 am #7545

Excellent! So I unchecked the all box in alternative view options. Then I went through and checked each box one by one while logging out and checking each time. This was the problem. However, instead of clicking the “all” box, I checked off each box on its own. All of the options are checked off in the alternative view box individually rather than through the “all” option. It works now. Its redirecting like it should. Thanks for all your help.

Posted: Wednesday Mar 7th, 2012 at 2:29 pm #7571

Very cool! Glad that solved it. :)

I’ll mention this to Jason, that “all” behaves differently than all checked individually.

Posted: Thursday Mar 8th, 2012 at 3:14 pm #7645
Staff Member

Thank you. We’ll take a look and try to reproduce this in our lab.

Viewing 11 replies - 1 through 11 (of 11 total)

This topic is closed to new replies. Topics with no replies for 2 weeks are closed automatically.

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.