latest stable versions: v150827 (changelog)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

About: Dan Stramer

Sorry, I've not written a description yet. I'll get to it soon!

My Latest Replies (From Various Topics)

Viewing 24 replies - 1 through 24 (of 24 total)
Author Replies
Author Replies
Posted: Wednesday Jun 19th, 2013 at 6:09 am #52183

When the user reaches the s2 member area from the powerpoint he is logged in, vut still he is redirected to the membership page.
If you use the login info I sent you you can see there is a red bar on top of the site – showing the user that he is logged in.
Please log into the site with you user and see what I mean.


Posted: Tuesday Jun 18th, 2013 at 5:55 am #52079

Hi Christian
Just tried and it still redirects the user to the “my membership options page”.
I’m sorry but this is a fundamental issue.
My client uses office programs (powerpoint, word) to present his products which are under the S2member protected area and he cannot have these links not working.
There must be a way to solve this as office programs are not rare.


Posted: Saturday Jun 15th, 2013 at 8:11 am #51995

Hi Cristian,


Posted: Saturday Jun 15th, 2013 at 5:20 am #51981

Hello Cristian
I added the code to the s2-hacks.php file and it still doesn’t work.
Would you like access to the site in order to fix this issue?

Posted: Monday Jun 10th, 2013 at 1:08 am #51709

Hi Christian
Thanks for your support, I added the code in the functions.php file as suggested in the stackoverflow discussion, but still the user is redirected to the membership page instead of the correct URL.

How can this be solved?
DO you need access to the plugin / site?


Posted: Wednesday Jun 5th, 2013 at 6:11 am #51405

Thanks Crisitian,
It’s very important since it’s in a presentation sent to customers with links to the secure area.
It happens also in word docs.

Couldn’t check it in OpenOffice.
The www is used in the site and also in the powerpoint.
When copying and pasting the link into the browser it does work, just when clicking on the link in powerpoint it directs the user to the membership options page instead of the actual page.


Posted: Saturday May 25th, 2013 at 6:52 am #50623

Thanks Christian
I added the .html and the .htm extensions to the “inline File Extensions” settings vut I am still getting the download prompt.
when trying to view the file via the URL, I get a blank screen:

The file I want the users to see is an HTML file playing a presentation.
Here is a print screen of all the files in the directory:

I just got it working by changing the URL to this:

Adding the /s2member-file-inline/ after the /s2member-files/ solved the problem.

Thanks for your help,


Posted: Thursday Mar 21st, 2013 at 2:22 am #45291

Thanks Jason,
Created the file and giving it a check.
Will update…


Posted: Wednesday Mar 20th, 2013 at 2:19 am #45196

Hi Jason,
Did you have a chance to take a look?


Posted: Monday Mar 18th, 2013 at 11:50 am #45049

Hi Jason,
I submitted the details again


Posted: Sunday Mar 17th, 2013 at 2:16 am #44967

Hi Jason
Thanks for helping here.
The file is a .rar file 22.5kb in size.
I would like to say that only when copying and pasting the url in the address bar the browser causes the error.
When clicking on the link in the webpage the download is ok.
I posted a dashboard login previously, I’ll do it again.


Posted: Saturday Mar 16th, 2013 at 12:58 pm #44933

Hi Crisitan
What does this line of code do?


Posted: Wednesday Mar 13th, 2013 at 4:41 pm #44533

I am using the s2 members files folder.
I submitted the site’s info as you requested.

Posted: Saturday Feb 9th, 2013 at 1:43 pm #41259

Thanks Kristoffer,
I just did it myself with a few “find and replace” in excel.
Just a heads up – please note that you would have to remove the double quotes showing up in rows like:
“Virgin Islands, U.S.”|”Virgin Islands, U.S.”

The system will give an error when importing


Posted: Monday Feb 4th, 2013 at 9:45 am #40727

Thanks for this code.
Is there an option of getting this list without the country abbr.
something like this:
Aland Islands|Aland Islands

Posted: Thursday Jan 24th, 2013 at 4:49 am #39329

Thanks Jason
I’ll take a look at the wp function

Thanks for your support.


Posted: Saturday Jan 12th, 2013 at 2:18 pm #37155

Thank you very much Jason, that did the trick!

Another question if I may – is it possible to have all child pages of a protected parent page to be also automatically protected? Or do I have to set a protection level for each page separately?


Posted: Thursday Jan 10th, 2013 at 7:23 am #36854

Any news regarding this issue?


Posted: Wednesday Jan 9th, 2013 at 6:54 am #36723

The sub_field does echo out the name or the url, that’s why I wanted to add it after the “file_download” part.
(The icon is showing up and so does the file name)
But if this can’t work , can I disable the prompt entirely?

Thank you

Posted: Tuesday Jan 8th, 2013 at 3:19 am #36551

I am using advanced custom fields to enter the URL for the file download, and it’s working fine.
When trying to integrate the php code for the skip_confirmation it’s stops working.
This is the code I am using – can you help out:

<a href="<?php echo s2member_file_download_url(array( "file_download" => "the_sub_field('download_link')", "skip_confirmation" =>true)); ?>"><img src="<?php the_sub_field('download_icon'); ?>" /><?php the_sub_field('file_name'); ?></a>


Posted: Tuesday Jan 8th, 2013 at 3:04 am #36550

But is there a way to remove the S2 prompt alltogether from all downloads?
I already have tens of files and would not like to change all the url’s with the shortcode.
In this project I will not need any JS prompt for the download.


Posted: Sunday Jan 6th, 2013 at 5:12 am #36374

Any news from Jason regarding this issue?
If it is possible, I would like to remove the JS prompt all together.
When a user clicks to download a file he will be directed to the normal browser download window.



Posted: Sunday Dec 30th, 2012 at 3:18 am #35785

Ok, thanks
will be waiting for your update
I think it would be best to have an option to configure the “system messages” from the s2 member admin – I’ll vote to that…


Posted: Sunday Dec 30th, 2012 at 3:11 am #35783

Hi Bruce,
Thanks for your answer, I added a filed named s2-a.php with the above code into the mu-plugins folder inside the wp-content folder. (wp-content/plugins/mu-plugins/s2-a.php)
also tried remaining the file to s2member-a.php

Still getting the original prompt message.


Viewing 24 replies - 1 through 24 (of 24 total)

Old Forums (READ-ONLY): The community now lives at WP Sharks™. If you have an s2Member® Pro question, please use our new Support System.

Contacting s2Member: Please use our Support Center for bug reports, pre-sale questions & technical assistance.